cd burner(s) not burning on comp.

I'm at my wits end here.... trying to diagnose a problem with a friend's computer. Basically, cd burners will no longer burn a cd in his computer (they used to). At first I thought it was drive (sony) so I replaced it with one from one of my systems (an LG writer) known to work.... nothing. Yet it will read a disk just fine. I've also tried different software (nero, roxio, music match, etc).

I switched it to another IDE channel - nothing.

I've made sure that DMA is enabled.

Properties for the drive are set to allow it to record.

I've reinstalled the drivers, i've also uninstalled and reinstalled the IDE primary & secondary drivers

not sure if it matters, but it's an MSI KT3 Ultra motherboard and an AMD Athlon processor.

anyone every have a problem like this before? any ideas?

I don't know where it is right now, but look for a cdburn.reg file or some kind of .reg file to fix this.

It may work

did you try a cd that is known to be recordable?

are you using a cd that can be written to?

did he do a spyware clean recently?

sometimes they'll attach themselves to known good files and delete those when cleaned.

stephen

ya, i've tried a few different kinds of blank cd's

no spyware clean that I know, but I think he had a trojan that was removed.

Try this

http://www.tburke.net/info/misc/aspi.htm

tried that link, used the aspi.exe utility and it looks like there was missing a few files... still doesn't work.

I think it's a lost cause barring a complete reformat/reinstall of windows.

"I think it's a lost cause barring a complete reformat/reinstall of windows."

Repair function usually fixes driver problems from hell.

Give this a try
http://support.microsoft.com/kb/314060/

I was going to do a windows repair but it won't let me because the windows cd is "older than the version of windows already installed"

I assume it's because of SP2 installed?