Memory Card question

Hi all,

I usually use windows explorer to transfer, copy and delete pics. However, yesterday was the first time I 'format' the memory card in windows expplorer. Usually I would simply delete pics or format it while using the digital camera itself if I wanted to wipe it clean. Now when I use the memory card, it says 'Memory card not initialised'. What does this mean and how can I get it working normally again? Any help and suggestions appreciated. Thanks in advance.

Okay, first of all let me say this clearly: I DON'T KNOW. I'm not sure what is causing this problem, and I'm really tired so I'm not exactly in the mood to think right now but the very first thing that I thought when I read your problem is basically, what did you format the memory to? Did you keep it the same or did you accidently format it to NTFS file system? I think most cameras use FAT or FAT32 (I'm way to lazy to go to the car to get my digital camera and see what format it is). Is the card simply not readable in the camera or is it not readable by your computer either? Also what type of memory card is it (Memory stick, compact flash, SD, etc)? Please check that it's formated to the proper file system and let us know the above information and then we might be able to help you more

Try to format it with your camera. If it still doesn't allow you to, contact the manufacturer and find your receipt for the thing. I had this happen a couple of months back and they replaced it free of charge.

Bad idea. Format the cards only with the camera.

Yeah, you probably have to format it with the camera.

I accidentally deleted the main partition of a memory card I had in a USB reader (lol). I stuck it in the camera and that fixed it.

Yeah, if you format it with your camera now it should work just fine.