OG mechanics.... I'm needin a little help.

 

This app sucks.....

IN for mechanic advice on how to fix app.

Lol

So my work truck is a 98 Chevy 3/4 ton. Yesterday I'm driving and the horn starts blasting and won't stop. I pull over to pull the fuse and I turn on my flashers and they aren't working either. As of right now I have a horn that won't stop, and no break lights or flashers. I jacked either the wiring harness under the steering column and would get the horn to stop, but it would come back: I inspected what I could but didn't see any bare wire, but couldn't really see it all. All the fuses are fine as well.

Does this sound like a short somewhere in that particular wiring harness? Or do they ever just fail and have to be replaced out of nowhere?

 

 

Connect jumper cables to a car battery and then attach the other end to your testicles.

Tug Dabone -

IN for mechanic advice on how to fix app.

Haha! I knew this response was coming.

Did you check the other fuses?

I would say its a short.

Fastnotch!!!!

Yep, all fuses are good. 

And thats supposed to say 'jacked with the wiring harness' not 'jacked either'. It's the one under the ignition switch, not the turn signal wiring harness.

OP right now 

 

Vegito Blue -

OP right now 

 

Haha dude pretty much!! Except it was a constant horn blast and I couldn't figure it out. People were staring, it sucked.

DonkeyBiscuit -
Vegito Blue -

OP right now 

 

Haha dude pretty much!! Except it was a constant horn blast and I couldn't figure it out. People were staring, it sucked.

Lol I have no idea what would cause that to happen if it wasn't someone intentionally fucking with you. 

Only thing I would predict is either a fuse or a fucked up cable somewhere. But you already said you checked the fuses so idk. 

What about the plates in the steering wheel itself? Maybe a plate got stuck and it won't let off the horn button

Have you checked the relay's?

HatchyMySackie - Have you checked the relay's?

I have not and honestly in not sure what those are. I'll look it up.

Vegito Blue -

What about the plates in the steering wheel itself? Maybe a plate got stuck and it won't let off the horn button

Disassembled it and didn't see anything weird. And dice it's multiple things wrong, I'm thinking it's something.

DonkeyBiscuit -
HatchyMySackie - Have you checked the relay's?

I have not and honestly in not sure what those are. I'll look it up.

Usually the fuse box under the hood has what looks like big fuses. They usually are squares about an inch on all sides. Its hard to tell of they are bad but on the diagram it should tell you what it controls. Or also the owners manual

Ahhh, yep I did pull a couple and check quickly when I was checking the fuses, but you're right I couldn't tell visually if they looked bad or not. I'll go by the parts store in the morning and try to get one, surely they aren't too expensive.

Sounds like either brake rotors or a Johnson rod