this site sux on firefox, why?

why is the site so fucking slow on firefox but works just fine on chrome?

You using adblock I hope?

this site sux on pretty much every browser.  

angryinch -

this site sux on pretty much every browser.  

Came to say this. Phone Post

i've been having problems like crazy, sometimes it works with frames, sometimes it only works without frames

I turned off adblocker here, but run ghostify because it's staggeringly slow without it (on Chrome).

 

Sometimes the ghostify blocks out almost 30 different pieces of garbage.  There is a lot of crap built into this place and yes, it will make the pages load slowly.

I had to clear EVERYTHING out of my caches to get it to work in chrome. works fine now though.

RPBJJ - I had to clear EVERYTHING out of my caches to get it to work in chrome. works fine now though.


Yeah, clearing the site's cookies doesn't help.  I guess they are using some cookies that are not showing up as mma.whatever or mixedmartialarts.whatever because when the site is fucked, I can clear all of those out and it still won't fix it.  

Works fine for me. Adblock plus, noscript and ghostery.

It's awesome on FF for me. A bit ago people with Chrome were having login issues.

Also use the "Disconnect Me" add-on. Better than Ghostery. Phone Post 3.0

Yeah it's bad on everything. IE is the worst for me though, pages load half way then stop 40% of the time.

This place has been wacky on Chrome for about 2 years now, and it starts once you log-in. The menu looks like a stairway, it goes up and around the "Search for a Fighter box" which is just randomly floating in the middle of the page.

I know not everyone has this problem but I get it no matter what computer I'm using. And I've told management before - I'm not using any plug-ins, resolution is normal, text size is default. It's like this as soon as you install Chrome.

Soup and Beer - 


You using adblock I hope?


I have ghostery

Sagiv Lapkin - 


It's awesome on FF for me. A bit ago people with Chrome were having login issues.


don't believe you.

it takes like 15-30 seconds for the page to load every time I click on a new thread on try to go to the next page.

happens at work and home on FF.

I'm on chrome atm.