Thread Load Time

Does anyone else have problems with time it takes to display threads here?

It works as normal sometimes, but usually it takes ages for a thread to load or not at all. I have to refresh multiple times until the thread appears!

I'm using the latest version of IE.

Quick, someone take his green arrow!

Kidding.

I don't know if it's still true, but blue names have/had priority on bandwidth.

I don't know about IE, I haven't used it in over a decade.

Lol at the green arrow snatch!

I use chrome, but it takes about 3 seconds after the thread comes up before it stops bouncing around where I can actually scroll through it.

r1ch - Does anyone else have problems with time it takes to display threads here?

It works as normal sometimes, but usually it takes ages for a thread to load or not at all. I have to refresh multiple times until the thread appears!

I'm using the latest version of IE.

ive been having this problem as well as login issues. Slow as hell on Firefox, IE seems to speed it up some but still slower than normal.

it seems ever since that last attack that the site has been screwy

I found slow loading times because of the social media widgets.

Installing Ghostery (free) for my browser brought load times right back up.

Chrome, Firefox and Opera users:

Install Ghostery (like JackFunk said), plus Adblock and Disconnect Me.

SnapLocally - Quick, someone take his green arrow!

Kidding.

I don't know if it's still true, but blue names have/had priority on bandwidth.

I don't know about IE, I haven't used it in over a decade.

lol

Silhouette - 
r1ch - Does anyone else have problems with time it takes to display threads here?

It works as normal sometimes, but usually it takes ages for a thread to load or not at all. I have to refresh multiple times until the thread appears!

I'm using the latest version of IE.

ive been having this problem as well as login issues. Slow as hell on Firefox, IE seems to speed it up some but still slower than normal.

it seems ever since that last attack that the site has been screwy

Its only been a problem for a few months so this might explain it.